'Share' button is missing for some video pages
Incident Report for Loom
Resolved
Share button should now be restored on all video pages.
Posted Jun 07, 2021 - 13:47 UTC
Identified
We've identified that the share button is missing on some video pages. Engineering is engaged and actively working on a resolution.
Posted Jun 07, 2021 - 13:41 UTC