Loom is experiencing degraded performance
Resolved
Degraded performance
Lasted for 19h

This incident has been resolved

Tue, Sep 19, 2023, 03:55 PM
5 months ago
Affected components
Recording
Viewing
Updates

Resolved

This incident has been resolved

Tue, Sep 19, 2023, 03:55 PM
19h earlier...

Monitoring

We’ve identified the issue and are currently monitoring. You may experience elevated latency during this time.

Mon, Sep 18, 2023, 08:11 PM