Video player page not loading for some users
Incident Report for Loom
Resolved
Video page issues are now resolved
Posted May 11, 2022 - 13:25 UTC
Monitoring
A fix has been deployed. Video page should be operational for all users. We are now monitoring for any ongoing issues
Posted May 11, 2022 - 01:09 UTC
Update
We've identified a fix and working on getting this to production
Posted May 10, 2022 - 22:44 UTC
Investigating
The video player page is not loading for some users. We are currently investigating this issue.

In the meantime, if you are running into this problem clearing your browsers cache may fix the issue
Posted May 10, 2022 - 19:26 UTC