Screenshots Page is Down
Incident Report for Loom
Resolved
The issue has been resolved and the screenshots page is fully operational.
Posted Aug 06, 2021 - 19:42 UTC
Identified
The screenshots page is not loading for all users. A fix is underway
Posted Aug 06, 2021 - 17:57 UTC